Viewing Landsat TM images with Adobe Photoshop
Ned Horning and Timon McPhearson

Version: 1.0

Creation Date: 2004-01-01

Revision Date: 2004-01-01

License:
This document is licensed under a Creative Commons Attribution-Share Alike 3.0 Unported
License. You are free to alter the work, copy, distribute, and transmit the document under
the following conditions:
•

You must attribute the work in the manner specified by the author or licensor (but not
in any way that suggests that they endorse you or your use of the work).

•

If you alter, transform, or build upon this work, you may distribute the resulting work
only under the same, similar or a compatible license.

To view a copy of this license, visit http://creativecommons.org/licenses/by-sa/3.0/ or send
a letter to Creative Commons, 171 Second Street, Suite 300, San Francisco, California,
94105, USA.
How to cite this document:
Horning, N. and McPhearson, T. 2004. Viewing Landsat TM images with Adobe
Photoshop, Version 1.0. American Museum of Natural History, Center for Biodiversity and
Conservation. Available from http://biodiversityinformatics.amnh.org. (accessed on date)

Center for Biodiversity and Conservation
American Museum of Natural History
Central Park West at 79th street
New York, New York, 10024 USA

Viewing Landsat TM images with Adobe Photoshop
Reformatting images into GeoTIFF format
Of the several formats in which Landsat TM data are available, only a few formats (primarily
TIFF or GeoTIFF) can be opened in Photoshop. If you have satellite image data in a format
that cannot be read by Photoshop there is a free software package called OpenEV that
converts many common satellite image formats to GeoTIFF so that they can be opened in
Photoshop. More information about downloading and using OpenEV is located in the OpenEV
information page.
This tutorial explains how to open a TIFF or GeoTIFF format satellite image in Photoshop. A
GeoTIFF image is a TIFF image and can therefore be opened with any program that reads
the TIFF file format. GeoTIFF is a popular format for distributing satellite imagery that is
packaged using one of the following two methods. The first includes all of the image bands
(channels) in one file. To open this type of image follow the instructions for "Opening and
displaying a multiband (Geo)Tiff format Landsat image". The other method is to have one file
for each image band. In this case there will be several image files (usually 6 or 7) with each
file representing one Landsat band. To open these single band images follow the instructions
for "Creating an RGB image from single band (Geo)TIFF images".
Instructions and an example of how to locate and download free Landsat TM imagery are
detailed in the Downloading Landsat TM Data tutorial.
Throughout these instructions, "band" refers to a single layer of the Landsat image. Each
Landsat band records the light energy for particular wavelengths similar to the way a black
and white film records the light from the visible wavelengths of light. At this point the details
about the different bands is not important, just remember that "band" refers to a layer of the
Landsat image and "channel" refers to the layer in Photoshop. If you are interested, more
information about what a band is can be found in the band combinations guide.

Conventions used in this document
•

"Channel" refers to the red, green, and blue layers in Photoshop

•

Pulldown menu commands appear in italics

•

Sequential pulldown menu commands are concatenated using "=>"

•

Dialog titles are in bold italics

•

Window titles are in bold

•

Parameter settings are enclosed in quotation marks

Opening and displaying a multiband (Geo)TIFF format Landsat
TM image
1. Open the file using File => Open and then navigate to the satellite image (Geo)Tiff file.
This will open all of the image bands in the file and will display the first three. The
image will appear quite dark but that is normal. We will enhance the colors so they look
better.
2. Click on the Channels tab on the Channels window or select Window => Channels.
This will display the individual bands in sequential order (band 1 at the top and the last
band at the bottom). The default behavior is to display the first three bands (bands 1,2,
and 3) as an RGB image. The remaining bands (bands 4,5, and 6 assuming the
original image had 6 bands) are listed as Alpha channels in the channel list.
a. Clicking on the boxes on the left-hand side of the Channels window turns the
individual bands on/off. If there is an "eye" icon in the box, then that channel is
currently being displayed in the image window.
b. In order to see the individual bands as grayscale images, click on these boxes
so that only the eye icon next to the band to be displayed is showing. Doubleclicking on an image icon without an eye to the left will deselect all of the other
channels and will display the image channel being double-clicked.

3. To create another RGB image using the channel assignment of your choice a new
image window must be opened. Before you open a new image window you need to
determine the appropriate size for the new window.
a. One easy way to do this is to click on the opened image and then select
Select => All to select the entire image. Copy the selection using Edit => Copy.
Next, to create a new image window click on File => New.
b. Type in the name of your choice in the "Name" text box at the top of the New
dialog window. The correct image dimensions should appear in the dimension
text boxes but if they do not then select "Custom" in the Preset Sizes dropdown

list, and enter Width and Height values equal to the original image dimensions
in pixels (to see the image dimensions make the original image active then click
on Image => Image Size to get the Width and Height dimensions).
c. The units dropdown menu next to Width and Height should be set to
"Pixels". Set Mode to "RGB Color." The Resolution setting can be set as you
like. Click OK to open the window.
d. After the new window is open you will see blank image icons in the red, green,
and blue channels of the Channels window since the new image is black. After
the RGB image is created it is handy (although not necessary) to tile the image
windows in order to evenly distribute the windows by clicking on Window =>
Documents => Tile. The next step is to copy image channels from the original
image into the red, green, and blue channels of the new image.
For the remainder of this example we will create an RGB image using Landsat TM channels
4, 5, 3 in red, green, blue order. These same instructions can be modified for any band
combination. Information about selecting appropriate band combinations to highlight different
features is available in the band combinations guide.
4. Click on the original image to make it the active image window. To select the entire
image click on Select =>All. Next, in the Channels window click on the image icon for
the "Alpha 1" channel since this is the band to be copied. Copy that image by selecting
Edit => Copy.
5. Click on the new image and then in the Channels window (click on the Channels tab if
this is not visible) click on the "Red" image icon to select that channel as the one in
which the band will be pasted. Select Edit => Paste and a copy of the 'Alpha 1"
channel from the original image should appear in the new image.
6. Repeat steps 4 and 5 to Copy the "Alpha 2" channel from the original image and Paste
it into the "Green" channel in the new image.
7. Repeat steps 4 and 5 to Copy the "Blue" channel from the original image and Paste it
into the "Blue" channel in the new image.
8. To see the RGB representation of this image click on the box to the left of the "RGB"
image icon. The RGB image representing Landsat TM channels 4, 5, 3 is displayed in
the new image window. The image will have low contrast but we will fix that in the
"Enhancement" section of this tutorial.
9. To modify the output RGB image simply Copy the desired channels from the original
image and Paste them into the channel of your choice for the new image.

Creating an RGB image from single band (Geo)TIFF images
1. Open the three single-band images that will be used to create an RGB image. Use the
File => Open command to open each of the single-band images. For this exercise we
will create an RGB composite using channels 4, 5, and 3 assigned to red, green, and
blue channels respectively. Therefore, to follow this tutorial open channels 3, 4, and 5
of your Landsat TM image.
Therefore, to follow this tutorial open channels 3, 4, and 5 of your Landsat TM image.
The images will be grayscale images (similar to black and white photography) and they

will appear quite dark, that is normal. We will enhance the images later in these
instructions.
2. To create an RGB image using the image bands that were opened in the previous step
go to the Channels window. If Channels is not visible, then navigate to and click
Window => Channels. The Channels window will open or be available as a drop down
window in the top tool bar.
3. Click on the arrow to the right of the word Channels and a drop down menu appears.
4. Click on the Merge Channels selection near the bottom of the menu.

5. The Merge Channels window appears. In Mode, select RGB, and make sure
Channels is set to 3. Click Ok.

6. Now specify the channels. Select Landsat TM channel 4 for the "Red" color channel, 5
for "Green", and 3 for "Blue", for a 4-5-3 RGB image. Click Ok.

Photoshop will now process the three channels into a single RGB image representing
Landsat TM channels 4, 5, and 3 and close the former images, which may take a
moment depending on computer processor speed. The image will appear dark and
somewhat flat, but can easily be enhanced.
7. Repeat steps 1-6 for any other band combinations you would like to view.

Moving around the image and zooming
As you zoom into the image to see more detail it is necessary to navigate around the image.
The easiest way to do this is to launch the Navigator window by clicking on Window
=>Navigator. In the Navigator window the area displayed in the image window is delineated
with a box (red is the default color) over the thumbnail of the image. To change the region
displayed in the image window click and hold on the red box displayed in the Navigator
window while dragging it to the region to be displayed. The new region will be displayed in the
image window.
The Navigator window can also be used to zoom in and out of the image. There are three
ways to change the zoom value in the "Navigator" window. The first is to move the slider (a
triangle under a line) located just under the image thumbnail in the "Navigator" window.
Another way is to click on the small pyramids (to zoom out) or the large pyramids (to zoom in)
to the left and right of the slider. The last option is to type in the zoom factor percentage in the
text box to the left of the small pyramids. Other options for zooming into and out of an image
and panning around an image are described in the Photoshop Help files.

Enhancing the brightness and contrast in Landsat images
When you first create an RGB Landsat image, it may be relatively dark and low in contrast. To
adjust this choose Image => Adjustments => Brightness/Contrast. Make sure that the Preview
box is checked, which will allow you to view changes as you make them. Then move the
slider for brightness to the right to make the image brighter. Move the contrast slider to the
right to make the contrast stronger. You can also directly input brightness/contrast values in
the boxes using positive or negative integers, to finely control changes in brightness and
contrast. Depending on the feature you are trying to highlight, increasing contrast may make
the image sharper and crisper. However, increased contrast can also decrease detail in overly
bright or dark areas, such as snow covered landscapes or deep shadow.

Enhancing the color in Landsat images
The goal of image enhancement is usually to make the image easier to visually interpret or
sometimes simply to make it look nicer. Although the data values in a Landsat TM image can
range from 0 to 255, typically most of the values cover from one fifth to one half of that range.
By "stretching" these values we can more easily discern subtle color differences in the image
and thereby more easily differentiate features in the image.
One of the simplest ways to enhance an RGB image is by using the Levels command. This
allows you to modify the three bands (RGB) together or each of the component channels
(Red, Green, and Blue) individually. These instructions are written as a step-by-step set of
directions but the best way to get a feel for how this can be used to enhance imagery is to
experiment with the different settings.
1. Click on the RGB image to make it active (make sure the "RGB" channel is selected in
the Channel selector window) then select Image => Adjustments => Levels to launch
the Levels window. In the Levels window make sure there is a checkmark next to the
Preview checkbox. This will ensure that the changes are automatically reflected in the
displayed image.

2. We will start by modifying all three channels (RGB) at the same time. To do this make
sure "RGB" is displayed in the Channel dropdown box. If you don't see the Channel
dropdown box it is probably because a single channel and not the RGB image was
selected. We also want to make sure we make use of the entire pixel range (0 - 255 for
Landsat TM images) so be sure the Output Levels text boxes have values of "0"
entered in the left box and "255" entered in the right box. This will force the little
triangles under the grayscale slider to be positioned at the extreme left (the black
triangle) and the extreme right (the gray triangle).
3. In the central part of the window you will see a histogram of the pixel values for all
three channels. The "X" axis of this histogram represents the pixel values of the image

with the extremes being "0" (on the left side) and "255" (on the right side). The little
triangles directly under the histogram are used to show how the input values (those
displayed by the histogram) are mapped (stretched) to the output range of "0" - "255."
The value specified by the position of the black triangle (this value is displayed in the
leftmost Input Levels box) will be mapped to "0" for the image display. The values
specified by the position of the light gray triangle (this value is displayed in the
rightmost Input Levels box) will be mapped to "255" for the image display.

Example:
If we typed "25" in the leftmost Input Levels text box and"150" in the rightmost Input Levels
text box we would force the pixel values in the images that are less than or equal to "25" to be
"0" and the pixels equal to or greater than
"150" to be "255" and then linearly scale all the
pixels in between. The equation would be:
DP = IP - MinP * (MaxRange / (MaxP - MinP))
Where:
DP = displayed pixel value
IP = input pixel value (if the input pixel value is less than the minimum input pixel value IP is
equal to MinP and if the input pixel value is greater than the maximum input pixel value IP is
equal to MaxP)
MinP = minimum input pixel value
MaxP = maximum input value
MaxRange = the range between the minimum and maximum output levels
In our example, if we wanted to calculate the display pixel value for a pixel with an input value
of 125 the formula would be DP = 125 - 25 * (255/(150 - 25)) = 204
4. A good way to start enhancing an image is to move the leftmost and rightmost triangles
under the histogram. Move the leftmost (black) histogram triangle to a position just to
the right of where the histogram starts. Move the rightmost (light gray) histogram
triangle to a position just to the left of where the histogram ends. By moving these two
triangles you will begin to see more detail in the image. Initially, it is best if the middle
triangle stays midway between the left and right triangle. The middle "Input Levels" text
box will be set to "1.00" if the middle triangle is at the midpoint.

5. From this point the process becomes quite interactive. Continue moving the histogram
triangles (including the middle triangle) until you have an image where you can easily
differentiate the features of interest on the image.
6. Another more flexible way to enhance an image is to enhance the Red, Green, and
Blue channels independently. To do this we will start with the Red channel. It is not
necessary to start with the Red channel although it is suggested to use the same
sequence to more quickly become familiar with this technique. To select the Red
channel click on the Channel dropdown box and select "Red" from the list. This does
not change the image, but does display the histogram for the Red channel in the
Levels window.

7. Repeat step 4 above to make an initial enhancement to the image.
8. Now select the Green channel by selecting "Green" from the Channel dropdown list.
Repeat step 4 above to prepare the Green channel.

9. Select the Blue channel by selecting "Blue" from the Channel dropdown list. Repeat
step 4 above to prepare the Blue channel.
10. Now comes the iterative part of going through each channel and modifying it until the
image looks the way you want. This may take a while but once you get the feel for how
a change to one channel modifies the RGB image you will be able to tailor the
enhancement the way you like.
11. When the image looks the way you like you can either save the image or just save the
color mapping information (this saves disk space since another image is not created,
only information regarding the enhancement controls is saved) using the Save button
in the Levels window. Saving the image may require significant disk space since it
creates another image whereas saving the mapping information only creates a small
file. If you want to use the enhanced image in another software program, you will need
to save the image.

Some tips for enhancing satellite imagery
1. If you modify the individual channels and want to get a sense of how well the colors are
balanced look at the light or white portions of the image, if they exist, such as clouds or
bright bare soil. These lighter areas are more sensitive to the color mixing. If the color
is not balanced the feature will look tinted instead of white.
2. If you are interested in a particular feature of an image you can create an
enhancement that is not very attractive for the entire image but does show the subtle
difference in the feature of interest. For example, if you wanted to see more detail in a
river to see sediment or thermal plumes you would specify the minimum and maximum
pixel values (MinP and MaxP) to very low values perhaps MinP = 20 and MaxP = 40. If
you do this it is best to zoom into the feature of interest so you are not too distracted
when other features get washed out. The same can be done for vegetation if you want
to differentiate subtle variations in forest cover.

Using filters to enhance TM imagery
Another technique sometimes used to enhance a satellite image is to apply filters. Two
common uses of filters are to smooth out noisy (extreme high and low pixel values) image
data and to sharpen boundaries of different features in the image. Photoshop has several
filters. When applying filters they can always be removed using Edit => Undo or by using the
History State window (use of the History State window is described in the Photoshop help
files). Here are a few filters that may be useful:
•

Filter=>Noise=>Despeckle - Blurs the image and can be used to reduce noise

•

Filter=>Blur =>Blur - Blurs the image and can be used to reduce noise

•

Filter=>Sharpen =>Sharpen - Sharpens the boundary between different features in the
image

Increasing detail by adding more detailed Imagery
Landsat images acquired with the Enhanced Thematic Mapper sensor (ETM) onboard the
Landsat 7 satellite include a high-resolution Panchromatic (Pan) band (15m resolution) that
can be used to provide more detail in a satellite image by blending this high-resolution band
with the RGB image created using the other bands.
One approach to do this is to add a new layer and paste the Pan band in it. To do this, select
Layer => New => Layer or click on the Create a new layer button in the Layers window. Use
a name, such as "Pan band", that describes the new layer and set Opacity to 30%, Mode to
"Normal", and Color to "None".
By double clicking on the Pan layer to bring up the Layer Style window you can adjust the
opacity and blending to make the image look appropriate. It is also a good idea to use the
Image => Adjustments => Levels command to enhance the panchromatic image. As with
most of the other techniques described here, the best way to understand the effects from the
different controls is to experiment with them.

Helpful hints for working with Photoshop
Photoshop is a large and potentially complex software package that works with Layers,
Channels, and Paths. However, building image products for presentation using Photoshop
can be rewarding with even a rudimentary knowledge of the program. One key element is to
understand that Photoshop documents can have many layers of information on top of each
other in a given file. You can add shapes and text easily to an image by adding new layers to
the image. Additional hints for working with images are provided below.
•

For most functions besides a specifically chosen tool, you will want to have the arrowshaped Move tool selected in the top right of the tool box.

•

You can open previously opened images quickly using File => Open Recent.

•

To change the size of the image, open Image => Image Size to specify height and
width using percent or pixel size to change the image to smaller or larger size.

•

You can quickly zoom in and out using keyboard commands on any selected image. To
zoom in on an image, hold down the Ctrl key while pressing the + key. While holding
down Ctrl, each press of the + key is additional zoom. To zoom out, hold down Ctrl
and press the - key.

•

To quickly change back to the full size of your image filling maximal space, simply
double-click on the hand-shaped Hand tool in the toolbar.

•

You may want to use an image for a poster, or postcard, or document that has
information other than the image. If you need to place an image into a document of a
different size, create the new document specifying the document size using File =>
New. Be sure the image you want is open and a layer. If it says background in the
Layers window, double click background to make it a layer. Then click on that layer.
Click and drag the image onto the new canvas to copy and paste it in one move. You
can now move it on the new canvas to whatever position is appropriate, as long as that
layer is selected.

•

You may change the orientation of your image by selecting the image layer and then

selecting Image => Rotate Canvas. You can either pick previously specified rotations,
or choose Abitrary, which will allow you to input the degrees, plus or minus, for fine
control of image rotation.
•

You may find that a cropped image is more useful. The Crop tool, third down on the left
of the tool box, is perfect for this. Click on the Crop tool, then click and drag a box
around the area you want to keep. Once an area is specified, you can fine tune your
selection by moving the corners of the box, or using arrow keys to move the crop box
up, down, or side to side, around the image area you want to keep. Press Enter to
finish cropping the image. All information outside the crop box will be discarded.

•

To undo any action you can hold down Ctrl and press Z. Photoshop also keeps a
record of all actions in the History window. If you have made a series of actions, but
you want to undo the last three, just click on the line above the last three actions in the
History window to go back to the state before those three actions.

•

Adding shapes or text for captions or titles to an image is very easy. Simply click on the
T for the text tool. Once the T is clicked, you can specify font, color, and size in the
toolbar above. While the text tool is clicked, type text wherever you like in the image
area. This will make a separate text layer in the Layers window. To move the text,
simply click on the text layer in the Layers window using the arrow-shaped move tool,
and then move text. Each time you choose the text tool, you will generate a new layer.
To work with different layers, just click the layer you want to modify in the Layers
window. You may also name layers to make them more informative. Double click a
layer in the Layers window, then type in an appropriate name.

•

The same instructions for text apply for creating shapes such as circles, lines, or
rectangles using the shapes tool. Arrow tips for lines can be specified in the tool bar
above once the line tool is selected. Orientation of shapes can be adjusted using the
Transform tool. Click on Edit =>Transform =>Rotate. Then click and drag the corners
or edges of the shape to rotate it as desired.

•

When adding multiple lines of text to images for presentation or display, it is often
useful to format the paragraph. Click on Window => Paragraph to open choices for
paragraph formatting. You can now choose left, right, or full justification, among other
options. Character formatting opens in the same window, just click the Character tab.

•

If your tool palette locations become disorganized, just click on Window => Workspace
=> Reset Pallet Locations.

•

You may sometimes need to line up multiple lines of text or shapes. Photoshop
provides temporary line guides for this purpose. Click on View => New Guide Choose
horizontal for a horizontal line guide, or vertical for vertical. Then move your cursor to
the ruler area to the top or side of the image area. Click and drag. While dragging into
the image space you will notice a line appear. Let up when the line is positioned on the
canvas where you need it. You now have a temporary line guide to use to line objects
up on. You can clear this line using View => Clear Guides.

Note:
The GeoTiff file format is a TIFF file format that stores detailed geocoding information along

with the image data. Even though Photoshop (and most other image graphics software
packages) is not capable of reading this geocoding information it can still read the image
data. Since Photoshop does not use the geocoding information this information is lost when
the image is saved. In other words, if you save a Geotiff file in Photoshop the output file will
not have any geocoding information. We are working on creating simple-to-use software to
take the geocoding information from the original GeoTIFF image and copy it to the image
after it has been processed by Photoshop. More information about the GeoTIFF file format is
available at: http://trac.osgeo.org/geotiff/.

